Anyone figured the cause of the all perks lvl0/knife damage dailies problem? (Steam)

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/

smith22

FNG / Fresh Meat
Oct 13, 2021
4
0
1
Hi,
Ive seen a lot of people asking about this over the interwebz, but could not find a proper solution yet: all my perks showing level 0, all my dailies are knife damage, no perk besides my name, but I have inventory, also when I start a solo/join a multiplayer game cannot start it.
So, in my case the fault is in my device: if I log in to Steam on my brothers computer and start the game everything works fine, if I log in with his profile on my rig its the same as for me (were both in the same ip, using the same router, he has WIN10 installed, I have WIN7, both using the same version of Comodo AV+FW). Well, Im no expert but I think the problem is that my game client cannot reach the server where this data is stored, because of somethings missing/wrongly configured.
Funny thing is, Im on a fresh OS, with clean KF2 install, and before the reinstall it worked flawlessly. Ive already gone through all the usual troubleshooting steps, and since nothing worked I took a look on the launch logs on both my and my brothers machine, and Ive noticed that some lines, in which the perk and vault data etc. should be reading from the server are missing from mine, it also had some lines showing "[EOS SDK] ConnectOnLoginCallback error: EOS_UnexpectedError". Its scary.
Im attaching both log files (the first is form mine, the second is from my bros comp), maybe it helps figuring this mother out, its pretty frustrating, especially in the middle of the event.
Hints anyone? Thanks for the help in advance!
 

Attachments

  • Launch-backup-2021.10.12-22.43.01_MYOWNRIG.txt
    16.7 KB · Views: 0
  • Launch_MYBROTHERSRIG.txt
    24.3 KB · Views: 0

Arcames

Active member
Please define "usual troubleshooting steps", KF2's support website has plenty of articles: https://support.killingfloor2.com/en/steampc-knowledgebase/category/killing-floor-2-pc Submit a ticket if you want help from official support.

Food for thought:
  • Did you add KF2 to your computer's firewall and any other security software? Here's an example screenshot featuring Malwarebytes and Window's built-in firewall: https://cdn.discordapp.com/attachme...825680069317361674/kf2_firewall_allowance.png The setup of your computer's security software may of course differ.
  • Did you add the required Steam ports/addresses as well? (if you are a steam user)
  • Avoid playing games over wi-fi or mobile internet solutions.
  • Whenever you connect a new device to routers/modems it's best to restart them. A fresh OS install equals new pc.
 

smith22

FNG / Fresh Meat
Oct 13, 2021
4
0
1
Thank you for your answer!

As I mentioned, Im on a fresh OS, and a clean Steam and Killing Floor 2 install, but Ive tried these:
- restarted modem, router
- multiple restarts of the computer/Steam/game
- checked Comodos firewall settings (its configured the same as on my brothers PC)
- ran the game windowed, in dx10 mode
- tried to start a game from console (loaded the map, but I couldnt start the game, it said "Waiting for players")
- verified game files
- emptied the games folder in "My Games"
- reinstalled the game
- checked if I had the right redistributables installed (yes, same as on my brothers PC)
- checked if I had the Steam cloud sync disabled, also checked Steam beta participation (its off)
- checked Windows date and time settings (it is set to sync with time.windows.com)

KF2 is added to firewall, looks the same as on my brothers computer (same version, same config of Comodo).
Tried to add ports as well but did not help, also there are no additional ports open on the other rig and works fine (and worked fine on mine prevoiusly).
Were both connected over wire.

So, my opinion still is, there is nothing wrong with our network or ISP (because then the game shouldnt work on the other rig either), its something with this particular computer, and it should be software/network settings related (since Im using the exact same hardware as before the OS reinstall), and it has something to do with reaching the perks server.
 

Arcames

Active member
- Turn off all security software and firewalls, restart devices to apply changes. Launch Steam & KF2. Did perks come back? If the answer is yes you have to sort out client-side connection issues related to security software.

Another test to consider: Disconnect your brother's computer from the internet, plug that ethernet cable to your computer and see if perks come back.
Yet another test: Download a free VPN and select another location before you launch Steam.
 

smith22

FNG / Fresh Meat
Oct 13, 2021
4
0
1
Thanks again,
Ive tried to completely disable the firewall, but did not help unfortunately. I have not tried to switch the two computers tbh, bc I borrowed a rig from work yesterday evening, which also runs Win7, tried it in place of mine and it worked fine (it was good at work as well btw). Ive tried to switch up the connection slots on the router tho, also tried another wired LAN card (Im connected thru that atm), but did not work either of those. So I dont think VPN would work to be honest, might give it a try, but I think the problem is narrowing down to my Win install. Are you aware of any update(s) for Windows 7 that is critical to run the game? Because I could try to check if its/they are installed properly.
 

smith22

FNG / Fresh Meat
Oct 13, 2021
4
0
1
Allrighty, I try to create a ticket, Ill be back with the results if it works out, it might help someone in the future.
Cheers!