[Question] Any way to completely disable texture streaming?

  • Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

octiceps

FNG / Fresh Meat
May 28, 2012
234
0
0
Is there anyway to preload all textures and completely disable texture streaming in this game, or is Unreal Engine 3 incapable of that? My system, with 8GB DDR-1333 RAM and 1GB GDDR5 VRAM should be able to preload all textures just fine. I simply hate the texture pop-in when spectating and entering new areas of the map. It causes a split-second hitch in the frame rate as well, and I've been killed a few times already just because my game stuttered at the wrong time.

So far, I've already disabled my AV and increased the texture streaming poolsize in ROEngine.ini from 140 MB to 512 MB. The only thing this has done is reduced the freeze during pop-in from 1-3 seconds down to a split second, but it is still there. I've also edited the line "bUseTextureStreaming=TRUE" to "bUseTextureStreaming=FALSE" but all that did is force no textures to be loaded, making the make completely blacked out, so the value must be set to true.

Any suggestions?
 

ZantuS

FNG / Fresh Meat
May 29, 2012
5
0
0
... It causes a split-second hitch in the frame rate as well, and I've been killed a few times already just because my game stuttered at the wrong time. ...

In addition to you and me, I'm sure there are a lot of people suffering from this. I wish someone will either fix this or tell us how to do it.
 

octiceps

FNG / Fresh Meat
May 28, 2012
234
0
0
Try this one
http://forums.tripwireinteractive.com/showpost.php?p=911384&postcount=74

The file to change is C://Users/USERNAME/Documents/My Games/RedOrchestra2/ROGame/Config/ROEngine.ini
If you read my OP carefully, I've already stated that I've looked at the ROEngine.ini file in that folder and there is no option to completely disable texture streaming without severe visual degradation. The one option that I turned off not only disabled texture streaming but blacked out all textures. I've tried that tweak you gave. It's increased the level of detail on the some of the textures and the foliage pop-in distance has been reduced but the pop-in and stuttering are all still there.
 

kalle

FNG / Fresh Meat
Mar 19, 2006
246
28
0
I'm also interested in this. You can improve things a bit by changing all LODBias=0 to LODBias=-2 in engine.ini (except maybe skeletal and particle). You can also increase MinLODSize= to your liking (I'd suggest 512 or 1024). This increases the lowest detail level but there will unfortunatly still be streaming.
 

Neil79

FNG / Fresh Meat
Sep 16, 2011
95
29
0
This is probably what is causing my issue as well as it sounds very much alike