Tripwire Interactive Forums

Go Back   Tripwire Interactive Forums > Red Orchestra 2 / Rising Storm Forums > RO2/RS Modifications > Level Design

Reply
 
Thread Tools Display Modes
  #1  
Old 04-24-2014, 04:17 PM
Catalavos's Avatar
Catalavos Catalavos is offline
Senior Member
 
Join Date: Oct 2010
Location: Baltimore, MD
Posts: 1,133
Default SdKfz 251 will not spawn

Hey,
I was about to send out the mssg. below because I have been pulling my hair out all day trying to correct the issue noted in the thread title. I figured it out and again it was something very simple; The Z value under "movement" in the actor properties was set to -5. Changed it to "0" and suddenly the SdKfz 251 magically appeared. So if you end up with a similar problem, that's how to fix it.


Included it anyway as a "learning experience"

Hi all,
Ok, this worked just fine the other day but now I cannot get the 251 to spawn. The UC works fine. I have tried pretty much everything at this point from closing the editor and restarting it to re-verifying the tool cache for both the SDK and the game. Also deleted the shader caches.

Method 1:
Get ROVehicleFactory_Halftrack_winter actor from Actor Classes
Add it to the map (rt-click>Add halftrack actor here)
Add it to the appropriate
Playerstartgroup volume
re-build pylon that the Playerstartgroup is located in
re-build geometry
Open PIE to see if it works
Fail.

Method 2:
Copy and paste halftrack in from another map (Barashka)
Follow above steps
Fail.
__________________

Reply With Quote
  #2  
Old 04-25-2014, 02:42 AM
c200k c200k is offline
Senior Member
 
Join Date: Apr 2011
Location: Saarland, Germany
Posts: 175
Default

How I hate such problems, thank you for posting!

I had problems to find the actor in content browser. Where do I have to look for it?

Copy&Paste from another map was successful, but the SDK tells me, that the Actors have a wrong GUID, so I would like to add them properly.
__________________
RO2 Tracker App for Android 4.x

https://play.google.com/store/apps/d...172.ro2tracker
Reply With Quote
  #3  
Old 04-25-2014, 07:57 AM
Catalavos's Avatar
Catalavos Catalavos is offline
Senior Member
 
Join Date: Oct 2010
Location: Baltimore, MD
Posts: 1,133
Default

Look under the Navigation Point >ROVehicleFactory>ROTransportVehicleFactory>what ever vehicle you want

And to fix the GUid thing just rebuild the pylon that the half track is in. You can select the pylon then right click the build paths tool to build just that one pylon. Also make sure you add the vehicle factory actor to a ROPlayerStartGroup.
__________________

Reply With Quote
  #4  
Old 04-26-2014, 02:36 AM
c200k c200k is offline
Senior Member
 
Join Date: Apr 2011
Location: Saarland, Germany
Posts: 175
Default

Quote:
Originally Posted by Catalavos View Post
Look under the Navigation Point >ROVehicleFactory>ROTransportVehicleFactory>what ever vehicle you want

And to fix the GUid thing just rebuild the pylon that the half track is in. You can select the pylon then right click the build paths tool to build just that one pylon. Also make sure you add the vehicle factory actor to a ROPlayerStartGroup.
...that's it. Thank you!
__________________
RO2 Tracker App for Android 4.x

https://play.google.com/store/apps/d...172.ro2tracker
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:55 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 - 2014, Tripwire Interactive, LLC