Tripwire Interactive Forums

Go Back   Tripwire Interactive Forums > Red Orchestra 2 / Rising Storm Forums > RO2/RS General > Ideas and Suggestions

Reply
Click here to go to the first Dev post in this thread.  
Thread Tools Display Modes
  #1  
Old 04-24-2014, 09:16 PM
Moskeeto's Avatar
Moskeeto Moskeeto is offline
TWIL Section Admin Staff
 
Join Date: Dec 2011
Posts: 1,998
Default Please fix the Workshop next

This is what I always get when I start up the game:
Spoiler!

(Look at the top-right corner.)

Every. Single. Time. It says "Downloading" followed by a bunch of random symbols like that. Then, it shows those random symbols followed by "download failed". In this example, there's too many symbols to see where it says "download failed". This always freezes my main menu for a couple of seconds.

I'm not even subscribed to anything in workshop. And if I do, it still does that and it messes up any workshop downloads.

As it is right, now, workshop integration is just broken. I don't mean to sound harsh, but that's the way it is. I think the system probably needs to be reworked from scratch because the workshop would be a fantastic feature if it worked properly.
__________________
Reply With Quote
  #2  
Old 04-24-2014, 09:18 PM
Jpz38 Hetzer's Avatar
Jpz38 Hetzer Jpz38 Hetzer is offline
Senior Member
 
Join Date: Feb 2013
Posts: 1,369
Default

I agree! I would like to download my custom naps ahead of time and a working workshop would be great. Also might get more custom map players too.
__________________
Currently know as Galm 2

Quote:
Originally Posted by PsychoPigeon View Post
Hetzer - the destroyer of imaginations
Reply With Quote
  #3  
Old 04-24-2014, 09:20 PM
Cwivey's Avatar
Cwivey Cwivey is offline
Senior Member
 
Join Date: Sep 2011
Location: In the hills! (of England)
Posts: 2,329
Default

I don't get that at all. And I'm subscribed to quite a few bits of content.

Freaky.
Reply With Quote
  #4  
Old 04-25-2014, 04:49 AM
thens thens is offline
Senior Member
 
Join Date: Jun 2012
Posts: 262
Default

Same errors for me, 100% reproducible.
It even displayed a download for Dota 2 the other day, something might be broken there.
__________________
Support the IOM and join the unranked IOM servers
Reply With Quote
  #5  
Old 04-25-2014, 05:04 AM
Moskeeto's Avatar
Moskeeto Moskeeto is offline
TWIL Section Admin Staff
 
Join Date: Dec 2011
Posts: 1,998
Default

Quote:
Originally Posted by thens View Post
Same errors for me, 100% reproducible.
It even displayed a download for Dota 2 the other day, something might be broken there.
Yeah. I've seen it trying to download CS:GO and Skyrim workshop content before. It has also tried to download an RO2 guide before and caused me to crash at the main menu every time. What fixed that crash for me? Asking the person who made the guide to delete it.
__________________
Reply With Quote
  #6  
Old 04-25-2014, 05:07 AM
thens thens is offline
Senior Member
 
Join Date: Jun 2012
Posts: 262
Default

Yeah, that sure is far from satisfactory.
__________________
Support the IOM and join the unranked IOM servers
Reply With Quote
  #7  
Old 04-25-2014, 08:48 AM
titsmcgee852 titsmcgee852 is offline
Senior Member
 
Join Date: Feb 2013
Posts: 510
Default

It could just be one map that's ****ing it up maybe?
Reply With Quote
  This is the last developer post in this thread.   #8  
Old 04-25-2014, 11:22 AM
Yoshiro's Avatar
Yoshiro Yoshiro is offline
In Soviet Russia, Yoshiro is a cake
 
Join Date: Oct 2005
Posts: 9,703
Default

We are working on several workshop issues but have had trouble reproducing them in house.

Issues that you see not just in our game but in multiple games sounds like a problem with workshop itself and you should contact Steam Support.

But if you guys can get us reproductions for any issues that will help us.
__________________

Pretty, what do we blow up first? - Myn Donos
Reply With Quote
  #9  
Old 04-25-2014, 12:41 PM
Jank Jank is offline
Senior Member
 
Join Date: Jun 2007
Location: Redwood City, CA, USA
Posts: 774
Default

That is odd, never seen that before.
__________________
Reply With Quote
  #10  
Old 04-26-2014, 08:23 AM
TheStranger's Avatar
TheStranger TheStranger is offline
Senior Member
 
Join Date: Nov 2005
Posts: 313
Default

I had this problem in RO2 and also in Killing Floor. There must be a few threads in the KF forums. The problem that solved this was to unsubscribe all workshop stuff - it is still there but doesn't check for updates anymore, so the lag is no more

So if you want new maps via the workshop:

Subscribe, let it download, start the game, check if the new map is there. If yes then quit and unsubscirbe.
Reply With Quote
  #11  
Old 04-26-2014, 08:26 AM
Moskeeto's Avatar
Moskeeto Moskeeto is offline
TWIL Section Admin Staff
 
Join Date: Dec 2011
Posts: 1,998
Default

Quote:
Originally Posted by TheStranger View Post
I had this problem in RO2 and also in Killing Floor. There must be a few threads in the KF forums. The problem that solved this was to unsubscribe all workshop stuff - it is still there but doesn't check for updates anymore, so the lag is no more

So if you want new maps via the workshop:

Subscribe, let it download, start the game, check if the new map is there. If yes then quit and unsubscirbe.
Like I've said before, I'm unsubscribed from everything. I even made sure to unsubscribe from anything in every other game. Workshop works fine for me in every other game, but I did it just in hopes to fix it. It didn't work.
__________________
Reply With Quote
  #12  
Old 04-26-2014, 09:18 AM
TheStranger's Avatar
TheStranger TheStranger is offline
Senior Member
 
Join Date: Nov 2005
Posts: 313
Default

Sorry I didn't see that you are already unsubscribed.

The problem in KF were also the big temp file archives, but I don't know if they were ever a problem in RO2. At least they caused the lag in KF. Here is the thread:

http://forums.tripwireinteractive.co...ad.php?t=96942

edit: Did you delete any old versions of maps or stuff from the workshop? You could just put them temporary into another folder.

Last edited by TheStranger; 04-26-2014 at 09:20 AM.
Reply With Quote
  #13  
Old 04-26-2014, 09:51 AM
Andreson's Avatar
Andreson Andreson is offline
Senior Member
 
Join Date: Dec 2011
Location: Republic of Moldova
Posts: 711
Default

Quote:
Originally Posted by Yoshiro View Post
We are working on several workshop issues but have had trouble reproducing them in house.

Issues that you see not just in our game but in multiple games sounds like a problem with workshop itself and you should contact Steam Support.

But if you guys can get us reproductions for any issues that will help us.
Try to subscribe to 20 or 30 items in the workshop section of RO 2. That almost guaranteed me to get issues with random crashes in RO2's menu and server browser.
__________________
http://www.coingod.nuzoka.com/signature.png
Reply With Quote
  #14  
Old 04-26-2014, 10:58 AM
titsmcgee852 titsmcgee852 is offline
Senior Member
 
Join Date: Feb 2013
Posts: 510
Default

I deleted all my workshop files and the problem went away. It's definitely an error in one of the workshop maps, and being as the majority of them won't work anymore because they need to be brewed now, there's no real loss in deleting them I suppose?
Reply With Quote
  #15  
Old 04-26-2014, 12:49 PM
Moskeeto's Avatar
Moskeeto Moskeeto is offline
TWIL Section Admin Staff
 
Join Date: Dec 2011
Posts: 1,998
Default

I did delete everything, of course.
__________________
Reply With Quote
  #16  
Old 04-26-2014, 04:19 PM
Andreson's Avatar
Andreson Andreson is offline
Senior Member
 
Join Date: Dec 2011
Location: Republic of Moldova
Posts: 711
Default

Quote:
Originally Posted by Moskeeto View Post
I did delete everything, of course.
I know it sounds weird, and it IS! My game crashed 80% of the time when I skipped the intro's. If I don't do that it might not crash (now it's stable after I deleted some workshop stuff).
__________________
http://www.coingod.nuzoka.com/signature.png
Reply With Quote
  #17  
Old 04-27-2014, 03:07 AM
Moskeeto's Avatar
Moskeeto Moskeeto is offline
TWIL Section Admin Staff
 
Join Date: Dec 2011
Posts: 1,998
Default

I'm not the only one: http://steamcommunity.com/workshop/d...4/?appid=35450
__________________
Reply With Quote
  #18  
Old 05-08-2014, 03:58 AM
Moskeeto's Avatar
Moskeeto Moskeeto is offline
TWIL Section Admin Staff
 
Join Date: Dec 2011
Posts: 1,998
Default

Yet another that was suffering from the same issues:
http://steamcommunity.com/app/35450/...41131068866160

Perhaps the problem is on Valve's end of the Workshop implementation, but why is it that I only get these problems with this game? Also, if it is an issue on Valve's end, perhaps you guys should bring this up to them to look at.
__________________
Reply With Quote
  #19  
Old 05-08-2014, 06:41 AM
Andreson's Avatar
Andreson Andreson is offline
Senior Member
 
Join Date: Dec 2011
Location: Republic of Moldova
Posts: 711
Default

Quote:
Originally Posted by Moskeeto View Post
Yet another that was suffering from the same issues:
http://steamcommunity.com/app/35450/...41131068866160

Perhaps the problem is on Valve's end of the Workshop implementation, but why is it that I only get these problems with this game? Also, if it is an issue on Valve's end, perhaps you guys should bring this up to them to look at.
I also had it! Somehow it fixed on it's own.
I think I had this in Autumn as well.
__________________
http://www.coingod.nuzoka.com/signature.png
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 03:46 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2005 - 2014, Tripwire Interactive, LLC