• Please make sure you are familiar with the forum rules. You can find them here: https://forums.tripwireinteractive.com/index.php?threads/forum-rules.2334636/
  • Weve updated the Tripwire Privacy Notice under our Policies to be clearer about our use of customer information to come in line with the EU General Data Protection Regulation (GDPR) rules that come into force today (25th May 2018). The following are highlights of our changes:


    We've incorporated the relevant concepts from the GDPR including joining the EU and Swiss Privacy Shield framework. We've added explanations for why and how Tripwire processes customer data and the types of data that we process, as well as information about your data protection rights.



    For more information about our privacy practices, please review the new Privacy Policy found here: https://tripwireinteractive.com/#/privacy-notice

Game Runs Terrible Since Last Patch

A6ftTooL

FNG / Fresh Meat
Sep 28, 2011
10
0
0
Hi guys, the game has been running awful since the last patch was released a week or two ago, I'm not entirely sure when the patch came out because it completely butchered the game for me and I haven't been able to play since

I get about 25fps on average with it spiking and dipping all over the place, prior to the patch i got a constant 90fps with everything set to ultra/high now it is unplayable

PC specs;
i7 2600k @4.5ghz
8gb 1600mhz ddr3 dual channel memory
ati5850 overclocked
11.8 drivers for my gpu

Does anybody have a solution to the problem?

Thanks in advance
 
Last edited:

PUTZ

FNG / Fresh Meat
Nov 21, 2005
4,564
634
0
Baltimore, MD, USA
Do you have an av or firewall that you need to let the exe through? We changed 2 things, neither of which would effect performance much.
 

A6ftTooL

FNG / Fresh Meat
Sep 28, 2011
10
0
0
Do you have an av or firewall that you need to let the exe through? We changed 2 things, neither of which would effect performance much.
Nope I even tried putting my local IP address in the DMZ so it bypasses my hardware firewall on the router, re-installed direct x and the redists that came with the game, verified game cache on steam. No dice. I'm not sure if it was the last patch or the one before that, I stopped playing for a while because it has been so bad.

I don't use a software firewall, even Windows firewall is disabled.
 

PUTZ

FNG / Fresh Meat
Nov 21, 2005
4,564
634
0
Baltimore, MD, USA
COuld you go into a match, and where performance is lowest, type stat perfdump into the console. When that has finished, exit the game. Attach that log file here.
 

Spindle

FNG / Fresh Meat
Aug 2, 2011
676
374
0
Belgium
Hi guys, the game has been running awful since the last patch was released a week or two ago, I'm not entirely sure when the patch came out because it completely butchered the game for me and I haven't been able to play since

I get about 25fps on average with it spiking and dipping all over the place, prior to the patch i got a constant 90fps with everything set to ultra/high now it is unplayable

PC specs;
i7 2600k @4.5ghz
1600mhz ddr3 dual channel memory
ati5850 overclocked
11.8 drivers for my gpu

Does anybody have a solution to the problem?

Thanks in advance
Yeah my game runs terrible aswell after the latest patch
 
  • Like
Reactions: Howitzer114

DiBBs

FNG / Fresh Meat
Mar 12, 2011
133
82
0
This is the first time my game has been unplayable.

It isn't FPS drop or anything. It's almost like i am lagging really bad, my avatar glitches all over when im running around, unresponsive most of the time with the controls, when i hit 'ready' to respawn, nothing happens...

This is all happening when my ping is 100 and lower. It feels like i have 300+ ping. All in servers that are around 70 ping for me.

No idea what happened, i haven't changed the config of my computer at all since i last played...
 
Last edited:

sirgreensock

FNG / Fresh Meat
Aug 31, 2011
2
0
0
This is the first time my game has been unplayable.

It isn't FPS drop or anything. It's almost like i am lagging really bad, my avatar glitches all over when im running around, unresponsive most of the time with the controls, when i hit 'ready' to respawn, nothing happens...

This is all happening when my ping is 100 and lower. It feels like i have 300+ ping. All in servers that are around 70 ping for me.

No idea what happened, i haven't changed the config of my computer at all since i last played...
Im having the same issue, game ran perfectly even on high settings online at the same time with my roomate. Now even at ping 50< I get weird glitches like im stuck in the ground, unresponsive menus and controls with my character hopping a few metres ahead every few seconds then stopping...
Even on lowest settings playing in an empty server with no one else in my household online I get the exact same problem.
 

Dirtybandit

FNG / Fresh Meat
Sep 4, 2011
319
122
0
Thats odd my game runs better now before I was getting 35fps on ultra, now I am getting 90ish fps on ultra @ 80% gpu usage . but it still dips way to much when doing anything like moving or shooting to about 30-50% usage. I also updated to the new battlefield beta drivers
 
Last edited:

DiBBs

FNG / Fresh Meat
Mar 12, 2011
133
82
0
Im having the same issue, game ran perfectly even on high settings online at the same time with my roomate. Now even at ping 50< I get weird glitches like im stuck in the ground, unresponsive menus and controls with my character hopping a few metres ahead every few seconds then stopping...
Even on lowest settings playing in an empty server with no one else in my household online I get the exact same problem.
Yup, this is exactly the symptoms i'm getting.

It's odd because this is the first time it's ever been unplayable for me. Even the beta played better.

Need a fix for this because this is literally stopping me for opening the game now.

And I know for sure it's not limitations of my computer. I built this rig to max BF3 out.